Bug #3628

Duplicated category after ticket transfer

Added by remi almost 9 years ago. Updated almost 9 years ago.

Status:ClosedStart date:05/30/2012
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:Helpdesk
Target version:0.83.2

Description

Ticket in Entity "A > B" affected to category "foo > bar" in root entity (recursive)

After transfer of the ticket in Entity "A > C", category "foo" and "foo > bar" are duplicated in entity "A > C"

Reproduce with SVN snapshot of 2012-05-29

Associated revisions

Revision 18573
Added by remi almost 9 years ago

try to fix transfer / import method, see #3628, to be checked

History

#1 Updated by remi almost 9 years ago

Seems to be an slashes issue.

In CommonTreeDropdown::findID() we have a "addslashes($input['completename'])" when this is already done before the call to FinID (and is not done for $input["name"] nor in CommonDropdown::findID()

Need more investigation.

#2 Updated by remi almost 9 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Applied in changeset r18583.

#3 Updated by moyo almost 9 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF