Bug #378

Authentification externe : IMAP/POP avec domaine dans le login

Added by Anonymous over 14 years ago. Updated almost 14 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:moyo% Done:

0%

Category:Helpdesk
Target version:0.65

Description

- Mes utilisateurs se connectent a l'aide de leur adresse mail ex : prenom.nom@domaine.fr

lorsque'ils utilisent helpdesk pour soumettre un problème, le champs "mon adresse de messagerie" est rempli, mais le domaine apparati 2 fois :
prenom.nom@domaine.fr@domaine.fr ... gènant !!!

peut on verifier si le domaine est déjà précisé dans l'adresse, le cas échéant, le rajouter...

Merci

History

#1 Updated by moyo over 14 years ago

Il ne devrait s'authentifier qu'avec prenom.nom bref leur login sur le serveur mail.
C'est le mode de fonctionnement de GLPI normalement.

#2 Updated by over 14 years ago

Ouaip, je suis d'accord, mais dans le cas d'un serveur multidomaines, l'utilisation de l'adresse email complète comme moyen d'authentification me laisse plus de liberté.

#3 Updated by over 14 years ago

en allant chercher des infos pour le bug 0000379, je me suis appercu que l'adresse de mes utilisateurs avait 2 fois le domaine.

je suppose que le compte est créé à la première authentification dans GLPI.. is that true ?

C'est peut etre a ce moment qu'il faudrait verifier si le login comporte ou pas un '@domaine.tld' ?

#4 Updated by over 14 years ago

Je viens de modifier mon adresse mail, mais lorsque je me reconnecte, le deuxième '@domaine.tld' se remet seul...

#5 Updated by moyo over 14 years ago

Oui vous avez raison. Je vais essayé de corriger cela aussi.

#6 Updated by moyo over 14 years ago

  • Status changed from New to Closed

Also available in: Atom PDF