Bug #4539

plugin fill the log of php errors

Added by gaio over 8 years ago. Updated about 8 years ago.

Status:RejectedStart date:09/25/2013
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

I've installed the plugin, using the nightly tarball as a source.

I've found the php error log file (files/_log/php-errors.log) full of error like:

2013-09-25 11:01:01
Notice(8): Undefined index: devices
Backtrace :
/usr/local/share/glpi/plugins/customfields/locales/devices.php:35 Toolbox::userErrorHandlerNormal()
/usr/local/share/glpi/plugins/customfields/locales/it_IT.php:111 include()
/usr/local/share/glpi/inc/plugin.class.php:172 include()
/usr/local/share/glpi/inc/plugin.class.php:98 Plugin::loadLang()
/usr/local/share/glpi/inc/includes.php:129 Plugin::load()
/usr/local/share/glpi/front/computer.php:34 include()

seems to me an error in the language files, probably a missed/wrong array definition, but i don't know how to fix it.

Thanks.

History

#1 Updated by dethegeek about 8 years ago

  • Status changed from New to Feedback
  • Assignee set to dethegeek

Please, can you try the latest release 1.6.0 for GLPI 0.84 ?

#2 Updated by dethegeek about 8 years ago

  • Status changed from Feedback to Rejected
  • Assignee deleted (dethegeek)

The bug affects a too old version of the plugin. No feedback with the current version.

Also available in: Atom PDF