Bug #5278

PHP Errors when deleting a computer

Added by blerohellec almost 5 years ago. Updated over 4 years ago.

Status:ClosedStart date:04/18/2015
Priority:NormalDue date:
Assignee:dethegeek% Done:

100%

Category:-
Target version:1.7.0

Description

i'm running GLPI 0.84.7 and CustomFields 1.6

I get some sql errors when I delete a computer.

SQL: DELETE FROM glpi_plugin_customfields_computers where id=3
Error: Table 'glpi084.glpi_plugin_customfields_computers' doesn't exist
Backtrace :
/var/www/glpi084/plugins/customfields/hook.php :347 DBmysql->query()
 : plugin_item_purge_customfields()
/var/www/glpi084/inc/plugin.class.php :1049 call_user_func()
/var/www/glpi084/inc/commondbtm.class.php :1261 Plugin::doHook()
/var/www/glpi084/inc/commondbtm.class.php :3101 CommonDBTM->delete()
/var/www/glpi084/front/massiveaction.php :116 CommonDBTM->doMassiveActions()
/var/www/glpi084/front/massiveaction.php

Indeed, plugin CustomFields is installed and activated, but none of the itemtype is activated. Thus, table _customfields_computers doesn't exist yet.

I had the same error with computerdisks (Volumes) and networkports (Connexions réseau). Indeed, my computer had computerdisks and networkports.
My computer had also components of different types, softwares. But I didn't get any error for those last ones.

History

#1 Updated by blerohellec almost 5 years ago

Forget about last sentence. It's correct not to have errors on components and softwares, because they were not deleted.

#2 Updated by dethegeek over 4 years ago

Please use the latest SVN revision for GLPI 0.84

#3 Updated by stoatwblr over 4 years ago

For what it's worth: I'm seeing the same thing on 0.85.4 using plugin version 1.7.0rc1

rev 85 from the 1.6-bugfixes branch wasn't pushed across to the 1.7 branch.

Patching it in by hand fixes the error.

#4 Updated by dethegeek over 4 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 90

Sorry for the long delay,

thanks to the investigations of stoatwblr ported the fix from 1.6 branch

#5 Updated by dethegeek over 4 years ago

  • Status changed from Feedback to Closed
  • Assignee set to dethegeek
  • Target version set to 1.7.0
  • % Done changed from 90 to 100

fix from revision 85 confirmed to be working.

Thank you for your helpful investigation.

Also available in: Atom PDF