Bug #5300

Ticket rich text : javascript error when switching to tab "all"

Added by orthagh over 4 years ago. Updated over 4 years ago.

Status:ResolvedStart date:05/05/2015
Priority:LowDue date:
Assignee:-% Done:

70%

Category:Helpdesk
Target version:0.85.5

Description

With Internet explorer browser, "uploadFile function undefined".

Impact on solution part :

- TinyMCE not initialized in content.
- All dropdown missing.

The js error occurs also on switching from solution to main tab (and vice versa).
On page reload, the error doesn't occur. Only on tab switching.

In attachment, a patch who fixes the issue but I'm not sure of the complete correction.

fix_ticket_tab_all.diff Magnifier (758 Bytes) orthagh, 05/05/2015 02:03 PM

Capture du 2015-06-03 09_15_28.png (140 KB) orthagh, 06/03/2015 09:20 AM

Capture du 2015-06-04 09_27_09.png (159 KB) orthagh, 06/04/2015 09:28 AM

Associated revisions

Revision 23516
Added by moyo over 4 years ago

Test to fix #5300
Ticket rich text : javascript error when switching to tab "all"

History

#1 Updated by moyo over 4 years ago

WHich version of Internet explorer ? I am unable to reproduce.

#2 Updated by orthagh over 4 years ago

Internet explorer 11 (Edge mode).

After some tests with last trunk version (2015/06/03), the js error "uploadFile function undefined" only occurs on "Solution" to "Ticket" tab switching (after page reload). The inverse switching doesn't trigger errors anymore.
So, TinyMce and dropdowns are correctly loaded.

Screenshot attached.

#3 Updated by moyo over 4 years ago

I think of a missing rand management.
Will try something

#4 Updated by moyo over 4 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Applied in changeset r23516.

#5 Updated by orthagh over 4 years ago

Not much better
See screenshot

#6 Updated by moyo over 4 years ago

  • Category set to Helpdesk
  • % Done changed from 100 to 70

Si tu as une autre idée ou patch qui fonctionne je suis preneur...

Also available in: Atom PDF