Feature #579

Search on fields by null value

Added by Anonymous over 14 years ago. Updated about 14 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:moyo% Done:

0%

Category:Inventory
Target version:0.68.2

Description

Good evening.

Would it be posible search for fields with null value?

It would be nice, for example, to look for computers (monitors, printers, etc.) that don't have a serial number on the database, so you can complete the info without browsing one by one.

Thank you for your great job.

History

#1 Updated by moyo over 14 years ago

  • Status changed from New to Closed

This is already possible in the SVN version.

see #576

#2 Updated by about 14 years ago

  • Status changed from Closed to Feedback

I have 5 monitors with an empty serial number. I've searched for null in Serial Number, but I have no results.

I've tried the same in the demo site https://glpidemo.sp2mi.univ-poitiers.fr, and I have the same result.

The same happens in computers, printers, networks, devices...

#3 Updated by moyo about 14 years ago

  • Status changed from Feedback to New

#4 Updated by moyo about 14 years ago

  • Status changed from New to Closed

(In r3883) recherche vide
fixed #579

#5 Updated by about 14 years ago

  • Status changed from Closed to Feedback

The problem is still there.

Just go to https://glpidemo.sp2mi.univ-poitiers.fr/, enter Inventory->Computers and you will see some of them without a serial number.

Now search the string NULL in Serial Number. No items. The same with Inventory Number. But if you do the same with Manufacturer or Type or Model, the results are OK.

Maybe it can be that searching for "IS NULL" in a text field is not OK?

#6 Updated by moyo about 14 years ago

  • Status changed from Feedback to Closed

you need to search empty and not NULL.
Searching empty is made using : ^$
nothing between begin and end.

#7 Updated by about 14 years ago

Thank you. :-)

The '^' character is special in this wiki and puts the text after it in superindex, so it disappears and then the text looks very small. :-)

Maybe it should be fine a tip that appears when passing the mouse cursor over the search textfields in GLPI giving some special instructions to search (null, ^, $, 1, 0) and in which cases they should be used....

Also available in: Atom PDF