FAQ Plugin Archires

Pour les parcs contenant beaucoup d'ordinateurs ces derniers se mettent sur une seule ligne soit en dessous soit au dessus d'un switch ce qui surcharge le graphique.

  • Pour remédier à cela il faut connecter la moitié des ordinateurs depuis le switch vers les ordinateurs (ces derniers seront mis en dessous du switch) puis connecter l'autre moitié des pc au switch (les ordinateurs seront alors placés au dessus).

Comment ajouter un type de matériel et l'image correspondante

  • A partir de la version 1.3, cela a été automatisé.
  • Avec la version 1.2, il faut :
  • a) Connaitre le type à ajouter.

Dans glpi_type_computers, repérer l'ID à ajouter. Par exemple (ID 3 = Rack).

  • b) Ajouter une entrée dans la table glpi_plugin_archires_config

Champs correspondants :

  • type glpi_plugin_archires_config = ID du type de glpi_type_computers
  • device_type glpi_plugin_archires_config = ID correspondant à l'ID déclaré dans config.php (Section // ITEMS TYPE)
  • img = le nom de votre image (que vous avez préalablement ajouté au répertoire pics du plugin)

Et de là elle sera automatiquement ajoutée dans la configuration du plugin et visible sur l'image.

Questions/Réponses

  • Q: En mode debug, j'ai des lignes type ''PHP ERROR : Notice: Undefined index: 6 in plugin_archires.functions_display.php on line 419''. De plus mon image ne s'affiche pas.
  • R : il peut y avoir un problème de path qui fait que l'utilitaire dot n'est pas trouvé dans archires/inc/plugin_archires.functions_display.php. On peut rajouter le chemin en dur (usr/local/bin/dot par exemple) dans ce script. ça se manifeste par un "sh: dot: not found" dans le log d'erreur d'apache. (La version 1.3 corrige ce problème)
  • Q: Mon image contient des matériels bizarrement reconnus (sous forme de losange).
  • R: Le nom du matériel ou le nom du type du matériel concerné par ce problème ne doit comporter que des caractères de base ( pas de "&", "/", "'", etc...)
  • Q: Mon image ne s'affiche pas dans GLPI mais le SVG est correctement généré.
  • R: Le lieu des matériels ne doit comporter que des caractères de base ( pas de "&", "/", "'", etc...)
  • Q: Mes images sont dégradées et/ou en Noir et Blanc
  • R: l semble que la dernière version de Graphviz (2.12 à ce jour) ne soit pas très bien supportée par le plugin (images dégradées et en NB).

La 2.8 est fonctionnelle, elle est téléchargeable ici : https://forge.indepnet.net/svn/archires/wiki/graphviz-2.8.exe